Freezing after 17.1 upgrade

Does anyone else have freezing issues after upgrading to iPadOS 17.1?

I get the black “Panels” welcome screen, but that’s as far as it goes.

My older iPad, which didn’t take the upgrade, still runs Panels fine.

Unfortunately, the one that is freezing, has all my comics on it. I love Panels and I’m anxious to get it working again

I just updated my iPad to 17.1, and it works with no problem.

Have you tried killing the app and opening it again? Does it happen every time?

Thanks for the reply!!

Yes, I have tried closing and restarting the app. And I have tried rebooting the iPad.

It is consistent every time. I don’t ever past the black welcome screen.

Can you install the latest beta and let us know if it solved the problem?

If you are not in the beta program, join our Discord and find the link in the #beta channel.

Thank you!!!

I installed iOS17.2 Public Beta. But no joy.

I still get the black Panels welcome screen, but the app stalls there.

After about 30 seconds Panels vanishes and the iPad home screen appears.

I can see that Panels is still running but it never gets past the black welcome screen.

Thanks again

Could you try getting some diagnostic files and sending them to us at ? :pray:

Wow! I had no idea this obscure a little corner of my iPad even existed.

Thanks again for your attention to this problem!

I emailed you the first analytics item and the two most recent.

Thanks again.

Thanks!! We got them!

It looks like something broke in the database of the app. I haven’t seen this issue before :thinking:

There is a way to delete and rebuild the database. You can go to Settings > Panels > Maintenance and enable Factory Reset.

This will delete the database and configurations like the external servers or favorites.
But it won’t delete any of your comic files.
Hopefully, it will work around the problem.

I will continue investigating and trying to reproduce the issue. But it might take long until I have a better solution.

Sorry for the inconvenience.

Thank you!
Sorry to say, this did not fix the problem.
I turned on Factory Reset. Rebooted the iPad. Checked that Factory Reset was still on. And then started Panels.
I still only get a black screen.
I understand that further investigation may take time. I’m looking forward to seeing if you are able to come up with a solution.
Again, thanks.

I’m very sorry to hear that :sweat:

Could you join our so we can discuss this in real-time? We got another report of this problem from another user.
If you join, ping me on DM, and I’ll create a channel to shorten the feedback loop and fix this as soon as possible.
Currently, we don’t have any leads

We just released a new beta 3.0.7, that aims to fix this issue.

Folks affected by this issue, please install it and let us know whether it fixed it for you. :pray:

Found the update in the App Store.
Applied it.
Rebooted my iPad.
Sorry to say, it did not fix the problem.
I do very much appreciate your attention to this issue. Thanks.
(Factory Reset is still set to on/green)

in the AppStore :thinking: it’s not in the AppStore yet.

The App store showed an update.
I watched the little blue circle go around as it downloaded and installed.
(I had looked there in the previous few days for an update without finding one until today.)
Should I watch there for the Beta you discussed?

So this time I got TestFlight and then downloaded Panels 3.0.7.
(Your instructions on how to do this were super clear. My bad.)
The new Panels beta still does not get past the black welcome screen, but there are two differences.
The iPad now gives me a notice that Panels has crashed, which was not appearing previously. Afterwards, there is a little orange dot by the panels icon.
I sent you a crash report.
Thank you again.

1 Like

Thank you so much. those crash reports were essential to understanding the problem.
I’m uploading another beta.

Not trying to hijack, but just realized I had this same problem during setup of a new device from a backup restore. Signed up for the beta and installed what TestFlight gave me. It launches Panels without the almost immediate crash. Now I need to test it with my actual data.

Perfect. The crash was caused by a missing attribute of one of the database models. So yeah, regardless of the data on the device or whether it was a backup restore or a new install… it could crash in some circumstances.

It affected users who skipped the penultimate version (went from 3.0.4 to 3.0.6 without installing 3.0.5), and/or sorted the library by file size or length.
That’s why it only affected a group of users.

It looks like I can use TestFlight to install previous versions of Panels, say 3.0.5.
Is that recommended?
Again, many thanks.

You can, but there’s no need. 3.0.7 should solve the issue even if you skipped 3.0.5.