Reading progress not being saved

Whenever I read something it doesn’t save the reading progress. Can someone fix this?

Hello !?!?!

@dani pls fix

Hey @Shinobu , we’ve been a few days off and I have just seen this message. Could you contact us at ? Send us your support identifier so we can find the logs and understand what is going on.

@dani I’ve noticed this too. Does Panels keep track of reading progress for external libraries like Komga? I know it doesn’t sync back to Komga, but does it internally keep track or do you have to download it to your device in order to track progress?

We keep track of it. Yes. We use the server URL + the Komga/Ubooquity comic identifier to tell the different reading sessions apart. When you download the comic we also add the file checksum to it so we have more ways to identify it.

Are you having problems only with Komga or other external servers?
I’ve tried to reproduce the problem and it works fine for me. But there are several potential points of failure. For instance, if the server URL / paths change or they make a redirect that ends up in a different URL every time you access a comic, a new session might be created every time. Giving the impression of reading progress not being saved.

If you can give us more information, it will probably help us narrow down the problem.
Also, if you send us your support identifier (found in the app settings screen) we can look into the database and try to see what information is being synced with our backend.

Thanks! Here’s the support info: Support Info:
Version: 2.9.1 Build: 202110171945 Env: Production (Testflight)
Support Identifier:

I switched to the TestFlight version in case that helped but it didn’t. If I’m browsing the comics on my phone I can see the option to mark as read.

If I try navigating my Komga library though, there are no such options.

I tried downloading the books and there’s still no option to mark as read.

If I read a book manually, it doesn’t tell me the next book to open. It pops me back to the main list.

Meanwhile there’s no indicator that I read any of it in the library. I couldn’t post more embeds so I included all the screenshots in an imgur album.

@dani Was this the info you needed?

Hey @GsMumbo sorry, I forgot to answer.

This is not really a bug but a lack of features. The remote libraries still need more work (we are on it) to have feature parity with the local library. We haven’t implemented “mark as read/unread” in external libraries yet (even if you download the file), or the progress indicator.

These features will come soon. Thanks for bearing with us :pray: