Problema para conectar con Ubooquity

Perfecto. Lo de la IP explica que puedas acceder desde fuera. NSAllowsLocalNetworking desabilita ATS para redes locales e IP fijas :+1:

Vamos hablando

Ey, misterio resuelto. :clap:

I still can’t get this set up with my server. is there anything odd with my connection settings? The error says it requires a secure connection to the server but it already is served over https

Solucionados todos mis incidentes con la última actualización. Ahora Panels tiene la mejor integración con Ubooquity de todos los lectores de cómic. :clap:

All my issues solved with the last update. Now Panels has the best Ubooquity integration in a comic reader. :clap:

@disrupted Is your certificate self-signed? Mine was and it didn’t work with Panels. I have to try with a Let’s Encrypt one.

no, it’s already Lets Encrypt cert. works perfectly fine within Safari and every other computer btw

We’ll set it up the same way to try to reproduce it. We’ll keep you posted.

1 Like

any news on this? did you already manage to set it up?

hey there, it’s been a while. any news to share? I would be up for beta testing if you need feedback.

Hey sorry for the long absence. It’s been a few hectic weeks and we’ve been a bit off.

I haven’t been able to reproduce the problem yet. I’ll spend the rest of the day working on Panels, and I’ll try to reproduce this.

@disrupted I’ve been testing it and it looks like it’s working fine on my side. But when I looked back to your screenshot, it looks like you’re only entering the domain without the URL scheme.
ubooquity.***** will try to connect to http://ubooquity.*****.
Could you try writing https://ubooquity.***** ?

if no scheme is defined, http is used by default. If this is the problem, I’ll make it clearer in a future release.

1 Like

can confirm, adding the https scheme is working as described. now here’s two things:

  1. the keyboard doesn’t allow writing https:// there (no colon symbol) so you actually need to copy paste the url
  2. I think it should default to https if you specify port 443 (standard https port)

anyways, thanks for pointing it out

Amazing :raised_hands:

  1. ouch! that’s true. we tested this with an iPad and it looks like : is not available in the iPhone keyboard. We just fixed it for the next release

  2. That’s a great feedback. We’ll give it a thought and very probably will implement it soon.

Algo sin mucha importancia, pero por si tiene fácil apaño:
Al importar desde Ubooquity, el nombre de archivo queda en el dispositivo con codificación URL. Por ejemplo:
Mortadelo y Filemón 124.cbz
O más evidente si comienza con una letra con tilde:
Época clásica 01.cbr

Gracias :raised_hands: esto debería ser fácil de solucionar. :+1: