Panels won’t connect to OPDS server

Hello - I’ve googled this issue for a bit and read a few other threads on this forum. Unfortunately, none of those suggestions solved the problem. Currently, I have a Komga server hosted behind a reverse proxy (SSL brought to you by certbot). Here is a general breakdown of what im inputting:

Alias: Komga
Port: empty/null
Username: user info
Password: user pass

I get the error “Could not connect to the server” with this configuration. I’ve tested the domain directly, and it loads the OPDS instance perfectly elsewhere. Within this forum, other users suggested using HTTP - but I get the error “The resource could not be loaded because the App Transport Security policy requires the use of a secure connection.” So, I checked my virtualhosts and made sure a standard HTTP connection was allowed, but the problem still persists.

I’m honestly not sure how to fix this, since everything I check is working as expected.

EDIT: In the meantime I’ve also tried directly connecting via the server’s IP Address, which also did not work. I’m certain this is a mixture of me setting up my server weird, and Panels not understanding my exact configuration - either way, any help in identifying what can be changed server side to make this work will be greatly appreciated!

FINAL EDIT: I’ve tried nearly every combination or configuration I can think of. On top of that, I’ve tried other apps - which work instantly with OPDS. So this is most definitely an app issue that should be looked into. OPDS is broken in this app - not sure what exactly, or why - but thats the only logical conclusion that remains.

Hey @DysfunctionalData

Could you create a temporary demo account for us so we can test the connection? We don’t need access to your content, only an active account. Feel free to share it on DM or send it to

Within this forum, other users suggested using HTTP

Could you point us to the thread where this is suggested? Definitely wrong. iOS only supports HTTPS connections to servers behind a domain name.
HTTP only works with IP addresses. But if you have your server behind a reverse proxy, an IP address won’t work because the reverse proxy won’t be able to resolve the route to the server.

I personally have a Komga server behind a reverse proxy.

Maybe having access to your server would help us debug the problem and hopefully improve the configuration flow.

The thread I was referencing was discussing, in general terms, how to connect Panels to Komga using OPDS. So the information I was referencing there isn’t directly applicable to a reverse proxy, but I wanted to be thorough in listing everything (however futile it might have been) that I attempted.

As for creating an account so that y’all may test against my server directly - I will send that to the email provided momentarily. I will include my username (DysfunctionalData) in the subject line so that it can be found more easily.

I’m sure the issue at hand likely is the result of some odd configuration choice on my part, but other OPDS apps were able to connect as expected - so i dont believe anything is broken per say, just slightly “unaligned”.

1 Like

Alright the dummy account details have been sent to the supplied email. Thank you!

1 Like

Thank you so much for the test account :raised_hands: . I was able to reproduce the problem and write a fix for it.

Here’s what it’s happening:

For a while, we had a lot of questions and support queries for help to configure OPDS. We need to cover all the technical knowledge spectrum. From network administrators to people that barely know what they are doing.
We tried to make the configuration interface a bit clever and fill the gaps when the user doesn’t configure things correctly.
We decided that, if the port was omitted, we would try to guess the correct port. Unfortunately, that heuristic is getting in your way for your current configuration. And it’s trying to use the wrong port.
We just fixed it and the next version of Panels will be able to connect with your server if you omit the port.

Nevertheless, you can make it work now if you set the port 80.

When you set a reverse proxy, even if it looks like you’re not using a port, you’re actually using the standard HTTP port. Every network service must use a port. Depending on the context, the port can be omitted and inferred from the protocol.
If you set the port 80, it should reach your service correctly. It’s not ideal, because it’s a bit counterintuitive. But, hopefully, in a couple of days, it will be fixed so you can simply omit the port.

Thanks again for reaching out and sending the test account.

That’s awesome, thank you! I normally come at these things with the perspective of “Well what did I do wrong now!?” so it’s nice to be wrong! With that said, the port 80 thing worked well.

As a side note, during my dive through various posts on this forum I stumbled upon some brief mention of integrating the Komga API into the app directly. I’m sure that will take a decent bit of effort, but I wanted to mark me down as a +1 for that feature. I think Panels has one of the best document viewers, so to pair that directly with a centralized host would be a dream come true!

Thank you for the help today and happy holidays if applicable

1 Like

Amazing! I’m glad it worked the problem around.