OPDS files downloading but not opening

Hey there, friends!

For a few releases now, I’m not able to open a cbr/cbz from an OPDS library anymore.

Previously everything worked.
Recently the following happens:


  • Add a new OPDS library - named it « comics »
  • go to Library > Libraries > comics
  • see folders load. Go in a folder. See cover previews load
  • tap a cbr or cbz file. Even a small one.
  • see the progress bar « download » the file.
  • cloud icon disappears indicating the file is local
  • in settings > manage space, see some space being used.

expected behavior

  • at end of download, the file can be tapped and opens

current behavior

  • nothing happens on tap
  • nothing is visible in the « downloads » tab


  • Tried with calibre-web and calibre’s OPDS servers
  • Tried without and with authentication
  • tried on iOS 16.2 - iPad Pro 12.9 and iPhone 14 pro max.

Thank you so much for the detailed report :raised_hands:

Let me look into this.

We haven’t tested Calibre in a while, and I have no idea what could be happening.

On the first examination… seeing the Download button disabled I would say the server is returning the metadata but not the OPDS acquisition item.

Could you provide a testing account so we can reproduce the problem?
Nonetheless, I will set up a Calibre and see if I can reproduce the issue.

Thanks for the prompt reply. The download button is disabled because I already tapped this file and it downloaded. I could see the cache metric in settings reflect it.

I’ll send an account in DM

Gotcha! thanks for clarifying. It must be something else, then.

Hi @unity

I’ve been debugging this issue with the test account, and I’ve found a few things to improve on Panels, but none explain the problem.
The main issue is that the server returns a 403 Forbidden error.

I can navigate through the different folders, but the server forbids downloading the file.

It looked like it was downloaded because Panels is not handling that type of error correctly, and an empty file was created locally. That’s why it wouldn’t open.
I’ve fixed it in Panels to show them as failed downloads. The next version will handle this case correctly.

It isn’t much else we can do on our side because the server is rejecting the request.
I’ve double-checked that we are sending the auth header correctly, and we are (otherwise that would affect everyone else). And I’ve tested the download with a few other servers without any problem.

Are you able to get some server-side logs maybe? I’m happy to provide all my request logs if you need them.

Let me know if we can do anything else to clarify what’s going on.

I’ll look into server logs to provide some.
As a side note: I’m able to select a file and “copy to iPhone”. I can then go to the local library and read the file so it’s definitely downloaded this way!

Let me check if the credentials I sent allow for Downloading books. This might explain that


Just added this permission.

Can you please try again ?

1 Like

It works now!!


I assume this was only disabled on the test account, right?

Yep, I know what’s going on then. Recently, we fixed a bug related to OPDS download files that prevented them from opening when the server didn’t support streaming.
Calibre doesn’t have it, but Komga and Kavita do. We usually use those and haven’t noticed that bug on other servers like Calibre.

The next Panels version will fix this issue, and OPDS downloads will work as expected.

In the meantime, please use the “Copy to my iPhone” option. We will release the next version probably next week.

Amazing! Thanks so much!!
I’m on the TestFlight beta. Will keep my eye on it !

1 Like

It should be out now :wink: Let us know if it fixed it