Missing ability to edit a connection service

I can’t find a way to view or edit the connection information and credentials for my ODPS server Komga. When I activate the edit mode I only see the option to delete the connection service but no way to edit the settings for it.

Related to that I found that in the last two updates all the connection settings for Komga were lost. A dialogue appeared, asking me to re-activate the account but that did not work. In the end the only available option was to delete it and re-create a new one to the same server with the same settings and credentials from scratch. Can you please preserve credentials and settings for connection during updates.

Hi @thampp

If you tap on the red circle with the white dash, you’ll get both the Delete and the Configure buttons. This is the system default behavior and design pattern. I understand that the red button might be confused with the Delete action, but that’s how Apple designed it :man_shrugging: I’m not a big fan either.

You can also swipe left on the cell and reveal the same two buttons.

The problem you’re describing is quite weird. Sounds like something is going on with the storage of your credentials.
Obviously, credentials and settings are preserved. Actually, we use Apple’s URLCredentialStorage that is the credential store that iOS provides to the apps. That way we don’t have to deal with the credential encryption and they are secure in your keychain.

We’ll try to investigate and reproduce the problem but we update the app several times/week (internal builds) and I’ve never experienced this. We’ll keep an eye on it.

Thanks. I found the configuration button. I actually tried the swipe- but only left-to-right :frowning: . I also tried long-press to get a context menu because Panels uses it in other places. How about using that?

The good news: I don’t think upgrading deletes connection settings any more.
The bad news: My connection settings are gone again this morning.

My Komga runs on a NAS that shuts down overnight. Can that have an impact?

One more completely unrelated item. Now that you have nested libraries it would be great if the breadcrumbs on top would not only allow to jump back one level up but would present all the levels to root so I can go back to root -or any other intermediate level - with one direct tap.

I also tried long-press to get a context menu because Panels uses it in other places. How about using that?

We try to stick to Apple’s proposed design patterns. Contextual menus are normally applied to items, not navigation cells. https://developer.apple.com/design/human-interface-guidelines/ios/controls/context-menus.
Swipe left is the system standard.

My Komga runs on a NAS that shuts down overnight. Can that have an impact?

Does it make it change the server IP or domain? :thinking:
It is possible that URLCredentialStorage is clearing the credentials if it can’t connect to the server.
We’ll try to reproduce the problem by doing that. Thanks for the additional info :raised_hands:

…breadcrumbs on top would not only allow to jump back…

We didn’t implement something like that because breadcrumbs scale badly on small screens. Also they are not a common design pattern in iOS. Especially on iPhone. On iPad they work a bit better…
But iOS already provides a native way of accessing previous screens inside a navigation stack. If you long-press on the back button, a popup menu with all the navigation history appears and you can jump back to the folder you want.

First of all: Thank you so much for your great support (and your great product of course).

You guys must think I am the most novice and naive iOS user. I feel a bit embarrassed to not having found the swipe on the config and the long press on the back button. In hindsight I think the long press was even shown in your little video when you announced the beta with the feature.

So my usability issues have all been addressed leaving only the weird situation that forced me to re-enter my whole Komga config 3 times already so far.

If it has something to do with my NAS shutting down over night then it must be something more subtle than just changes in IP address. Yes, the configuration is by IP because I don’t have a local certificate (it’s not exposed to the internet) and can’t configure https. I would have a local host name but I understand I can’t combine that with http. But in any case that should not matter: NAS/Komga run on a fixed IP/Port and reliably come up with the same every morning.

My problem may have different root cause altogether: The latest quirk was that later today when I restarted Panel again I suddenly had two connections configured to my Komga. No NAS shutdown in between. The configs look identical: Same name, same configuration data. Both work fine. Less disruptive than having only one and that one being corrupted/emptied and being forced to delete/reconfigure. But still confusing. And who knows how many of them will work tomorrow :slight_smile:

Below is a screen shot of the current situation (user name is redacted - in reality my email is there)

1 Like

Nothing to be embarrassed about. At all. Even though most of those gestures and design patterns are the standard in iOS, they are not necessarily super intuitive. It’s totally normal to miss some of them if you don’t know. The longpress to show the navigation history for instance… it’s quite hard to discover if you don’t know it exists.

Thank you so much for all the information about the OPDS server. This is super useful.

Here’s my hypothesis:

  • something it’s going on with the credentials store. I’m unsure if it’s something on your device, a bug on our end, or an edge case we are not handling correctly.
  • when you open the app, we try to restore the credentials to add the server to the list. If we can’t restore the credentials, if I recall correctly… it doesn’t appear in the list.
  • we allow adding the same server twice. we don’t have a strong reason to support this decision. Some people might have multiple servers running on the same machine and we didn’t want to prevent them from adding them. We could have checked the whole configuration (host + port) but it was easier to simply allow it :man_shrugging:
  • I think you opened your app, somehow the credentials restoration failed thus the server didn’t appear on the side menu. Then you added it again and that created a new record in the database.
  • The next time you opened the app, we were able to restore the credentials and the missing server started to appear again.

I’m going to revisit how we store the credentials and I might change it. :thinking:
We’ll keep you posted.

If you find out anything else, do not hesitate to post it. Any info is valuable.

Thanks for the help :raised_hands:

Just to chime in, I’ve been using an iPad since the original one and TIL that you could long press navigation buttons for contextual menu of history, so no worries, OP.