Komga + Panels / OPDS setup help / guide?

Hello,

I need some help trying to figure out where I went wrong.

I have Komga running on my local network on port 8080. It has my comics but no sorting beyond pointing to the directory so far.

I can access Komga web interface from my iPad and get the “full” experience.

I try to set up OPDS connection with my Komga server using the Komga admin account and I get the SSL error. Same if I use a test account w/ no permissions.

OTHER NOTES:

I am using the komga docker container and MACVLAN to expose the container to its own IP. Previously I mapped komga:8080 to server:8880 same results.

Even though I’m on the LAN I seem unable to set up an OPDS connection using HTTP as well.

Where am I going wrong?

Thank you,

N

Here is what I finally got to work:

Host: http://(IP address)/opds/v1.2/catalog
Port: 8080

1 Like

Hello,

That worked for me as well.

If anyone else is having this issue remember it needs to be HTTP not HTTPS

:thinking: I think we could fix this automatically under the hood.

We could try changing the URL scheme if it fails and try with/without SSL to simplify the configuration.

Thanks for pointing it out.

I’m using HTTPS - you may just need to set it to a different port.

I’m also trying to setup Komga. I’m using a reverse proxy for komga (komga.plxxxxx.xx) and the format as above. Komga is running in docker with the 8080 port mapped to 9696 internally. (If that makes any difference

The error is about App Transport Policy requiring a secure connection

Any help greatly appreciated

Never mind! It worked with https not http!!

1 Like

Hi, I cannot connect my friend’s komga server with panels.
When I put https I receive a request timed out (the server is ok)
When I put http (the true server) I receive the App Transport Policy

Host: http(s)://xxx.xxx.net:1234/opds/v1.2/catalog
Port: 1234

Any advice ?
Thanks

Sounds like your friend’s Komga is not serving over HTTPS (hence the timeout). iOS requires https connections when using domain names (App Transport Policy). The only solutions are enabling https on the server-side, or accessing it using an IP address instead of a domain name.

3 Likes

Thanks a lot, it works with IP address !

1 Like

I’ve recently set up a raspberry pi komga server and using panels with it has been awesome!

2 Likes