iOS 14.1 minimum requirement

@dani @victor


I don’t want to be ungrateful or anything. On the opposite, I love your lovely crafted app and I just bought the premium yesterday, and I’m grateful that I did and supported you. You all deserve it. :blush: :heart:

But now I see that a new update is out…and it requires iOS 14.1… :cry: why you had to require 14.1 :disappointed: I’m using Panels on an iPad Pro 12.9" which I cannot update to that iOS. So I’m stuck with it at 13.4.1.

Please…pretty please. Is there any way you could lower the requirements…like to iOS 13 or so? I really love this app so much…but now I’ll never get any updates. Please. I’ll continue to support and tip…but please, if it’s possible to do something about this. :pensive:


Hey @vic000047

Thanks for your kind words.
About the iOS 14.1 requirement, we need to keep bumping the minimum requirement to be able to use newer APIs. If we don’t increase it, we wouldn’t be able to use SwiftUI or the new UICollectionView APIs, that are quite important to us, in order to keep improving the UI.

We plan to support latest major version minus one. That means that we would normally support iOS 14 and 13. But given that all of the iOS 13 devices can upgrade to iOS 14, and we are quite close to the iOS 15 release, we’ve decided to bump it to 14.1 directly.

iPad Pro 12.9" are compatible with iOS 14, including the 1st generation iPad Pro 12.9".

You can check the compatibility list here:
As you can see, yours its on that list.

iOS 14 is compatible with all of the devices released after and including the iPhone 6S. It was released in September 2015. That’s 6 years of devices support.


I know about the compatibility, but there is another problem with my iPad Pro 12.9” 2nd Gen, which doesn’t allow for me to safely update.
I stupidly bought it from someone and it has some weird stuff which after the update it locks me out. :pensive: The only Apple device I haven’t bought as new…but it’s the only and last one.

Anyway, I understand and you’re completely right about the need to bump the minimum req iOS.

Oh well…I’ll try to update and see what happens.:man_shrugging::sweat_smile:

Sorry for bothering. And anyway it is, your app is a gem :gem: and I love it. Don’t stop improving it.
Wish you all the best. :pray::heart::clap:

Oh, that’s too bad :sweat:

I hope you can figure it out. :crossed_fingers:

It’s not a bother at all. Always happy to clarify our decisions. :heart:

Best of luck with your upgrade.

1 Like

Curious how it now says iOS 11 or later…and it starts the download, but when to install…it cancels automatically :sweat_smile:

Is something broken? Maybe…a workaround for me. :rofl:
Maybe I should stop trying, until I’m not breaking something…:roll_eyes:

Not sure why it’s showing like that on the AppStore but yeah… there’s no workaround possible. The binary is simply not compatible with older versions.

1 Like