Empty OPDS feed from Mylar

I have Panels on my iPad Pro iOS 15.3.1

Mylar3 and Komga are running on my home server. I can connect and stream comics smoothly with Komga’s opds. However, with Mylar’s opds I can only download comics. If I try to stream them, I can browse folders until I get down to the series level, then all I see is empty series folders.

So Komga opds works with both import and streaming. Mylar only works with importing.
I’ve tested on chunky and I can both stream and import with Mylar’s opds. Any tips on how to get it working or is this a known issue?

I guess that Mylar is not returning the thumbnail for the individual comics.
Panels requires that OPDS servers return the file thumbnail to appear on the library. The library design expects to show artwork, not file icons. It doesn’t look nice.
But it looks like this decision makes it more confusing and provides a worse experience.

We’ll change it to allow OPDS servers to show content without artwork.
Edit:

I just realized that we can’t remove this requirement because reading sessions depend on that thumbnail.

Could you create a test account for us so we can test the implementation? I’ve tried to set Mylar up multiple times with very disappointing results.
If you can give us access to a testing server (by DM please), we’ll gladly make the change and test it.

Did you need access to a Mylar opds server or access to a full Mylar instance? Also when trying to dm it says I cannot send a message to you.

Mylar opds is more than enough.

Also, if you can get a couple of examples of the OPDS feed, that also works.

What I really need is the OPDS XML feed so I can test the changes.

Thank you so much for the testing account. I was able to track the problem down and fix it.
It turns out that Mylar is returning a full URL outside the server. In this case, they are hot-linking comicvine images, instead of serving the image from the Mylar server.
Panels is expecting a relative path, not a full URL, and this breaks the thumbnail calculation logic. Given that we also require a thumbnail to present the files, they don’t appear.

I’ve fixed it by allowing full URLs, so now they appear correctly.

We are releasing a new version (2.12.0) very soon. This fix will be included in the next one (2.12.1). Probably during the weekend/early next week.

1 Like

No problem! Glad to see you got it working. I really appreciate the app and the responsiveness of the development team.

2 Likes