Double-page landscape viewing is jittery on iPadOS

hi. I’ve been enjoying using Panels recently, but something I’ve noticed lately is that reading comics in double-page + landscape mode often flickers or jitters backwards whenever I turn to the next page. I think I’ve narrowed down how to reproduce the issue, and I have a workaround in case anyone else is seeing something similar.

device/app info:
iPad Pro on iPadOS 15.7

Support Info: 
Version: 2.13.4   Build: 202209201020   Env: Production 
Support Identifier:

what’s happening:
I’m reading manga (right-to-left) from .cbz files, which I imported from Dropbox into my device storage (using the Panels integration with Dropbox).

whenever I turn the page, Panels flickers and sends me back a page (meaning I have to try to turn to the next page twice nearly every time).

I’ve noticed that sometimes after the flicker the pages are grouped differently - so occasionally the page that was on the right will be on the left side after the “flicker”. I’m guessing it’s something to do with the fact that I’m double-page viewing and Panels is figuring out the correct grouping of the pages right as I turn to them. once it knows how to group the pages, it won’t flicker anymore and you won’t see it happen for that page ever again.

I’m currently working around the issue by basically pre-loading the whole comic before I start reading. when I start a new volume, I tap the middle of the screen to bring up the pages view, then I quickly swipe through all the pages to force Panels to figure out the page layout ahead of time. since I started doing that, I haven’t seen the rubberbanding between pages.

it’d be great if the issue could be addressed in a way that doesn’t interrupt reading. I get that if you don’t know how pages need to be grouped ahead of time, sometimes the page on the right might need to get moved to the left. but maybe there could be a setting to pre-load comics when you open them or to at least pre-compute the page layouts? idk, if I’ve misunderstood the issue, feel free to ignore those suggestions.

so yeah, if anyone else is running into this super niche issue, I hope that workaround helps.

Thanks for the feedback.

Yeah, this is on our radar, but fixing it completely requires some work that we haven’t been able to do just yet.
Your hypothesis of the problem is 100% correct. We calculate the layout on the fly and, depending on the page’s weight, number of pages, etc, it can be more noticeable.

We are currently working on other stuff, but fixing the double page reader is very high in our priorities.
Hopefully we can fix it soon.

1 Like

totally understandable, thanks for the quick response!

1 Like

Are you setting the page grouping first? Tap the screen, bring up the pages view, long tap one of the images and choose “Group from this page on.” (choose the correct grouping start so that the page gutter is in the middle of the screen and not at the outsides. If you got it right, double-wide spreads won’t have a single page before or after them.). I’ve noticed that as soon as I do that, it won’t flicker anymore.