Difficulty adding Calibre OPDS

Can anybody help? I’ve input IP, port and username/password and it always fails to connect. I can connect to the web server via a browser but just not via Panels to Calibre OPDS

THe OPDS URL is usually different to the URL you input on your webbrowser. WHat do you use as an OPDS provider, and which URL did you input?

I’m using Calibre and I put down http://192.168.1.xxx and I set a username and password too

Then you have to input http://192.168.1.XXX/opds

(by the way, there’s no need to masquerade local IP addresses, no one can access it outside of your network)

Unfortunately just says unable to find server

Are you connected, via WiFi, to your local network?

As @foux suggested, it should connect if both devices are on the same network and you use the IP address and port that Calibre is using.

In my case, the configuration looks like this:

What do you see on your computer browser if you type your OPDS URL ?
Something like

You should see the feed, similar to this:

If you try to open it on your iPhone/iPad, Safari should show an error message like this

If you don’t, it means both devices can’t see each other and you have a local network configuration problem.

Hey Dani,

Thanks for your reply, much appreciated! I did finally manage to make the connection by disabling username and password, I confirmed server operating by checking localhost:8080/opds and finally I tried to configure in panels again and input and bingo, connected first try! Thanks again :blush:

Awesome! I’m glad it got solved :raised_hands:

1 Like