Can't connect to SMB service since iPadOS 15

I am trying to import files in version 2.9.0 using the SMB connector. My SMB server is a Samba service running on Arch Linux, with “protocol = SMB2” set (I’ve also tried setting it to SMB3, for what it’s worth).

On iPadOS 14, this worked just fine, but when I upgraded to iPadOS 15, it started telling me it can’t connect to the SMB server. I tried deleting the connector and recreating it, but now it just won’t make it at all, saying “Couldn’t list shared volumes.”

Thanks for letting us know, we will check that out soon!

Hi Victor,
any news on this issue?
I just activated a trial and I need to import my comics from a samba share, and I’m having the same issue as evaeva.

I tried with the “Files” stock application and that one is able to connect. Only difference is that I haven’t set any authentication on the samba server, so in the “Files” app I connect as guest (the panels app requires insted a user/password).

Any help will be appreciated.
Andrea

I am having the same problem, just reinstalled the application so it should be the latest version.

–Mark

Hey folks, sorry for the late reply.

Apparently, iOS 15 got a bit more strict in terms of SMB authentication and it requires the server to give explicit permissions to accounts.

(AMSMB2 is the open-source library that Panels uses to connect to SMB servers)

We were able to reproduce the problem and this configuration fixed it for us.

Please, make sure your server is configured this way and let us know if it solved the problem.

We plan to improve the feedback in the app and explain how to configure the server.
Additionally, @AndreaWozzup , we will add support for anonymous guest accounts in the future.

What is needed to be done on a Windows 10 computer? I previously used a password in Panels. For reference, I can still connect to SMB with the Files application.

It seems like I can “Import from Files” through my SMB connection there.

Unfortunately, I don’t have a windows machine to test. I’d recommend adding a comment to this thread and watching for any updates: