Cannot continue streamed comic from “Reading Now”

I was streaming a comic from Komga and stopped 21% of the way into it. I now see that in my “Reading Now” section, but when I tap on it to pick up reading again I get the following error message

Missing title
The title you are turning to open is not on this device.

Since streamed issues are appearing in “Reading Now”, it would be great if we could resume reading them with a simple tap. Seems like a bug.

You should be able to resume it. Did the server change, or maybe you’re trying to continue the reading on a different device that doesn’t have the server configured? We store the steaming comic URL that contains the server host. The app shows that error if it can’t connect to the server.

It sounds like the app can’t access the streaming source.

I’ve just tested it on my devices, starting on an iPad and continuing on an iPhone, and it works as expected.

We want to improve many things regarding connected services + multiple devices. We can improve that error message for sure. But I’m pretty positive that it’s not a bug, but the app is not being able to connect with the server.

The server hasn’t changed, and it’s same iPad. Nothing has changed as best I can tell.

I just deleted my session from “Reading Now” and loaded it back from the ‘On Deck’ folder of Komga (via Panels) to test again and it’s the same thing. If I tried to resume from “Reading Now” then I get the error.

Interestingly, if I go back in to ‘On Deck’ folder and open it from there it will immediately pick up where I left off. Seems like an issue with reading sessions or the “Reading Now” screen.

:thinking: that’s odd. It works fine to me.

I’ll look into it though. Thanks for flagging it!

I was having this issue and I found a solution: make sure add the port number in host address as well.
http://(ip address):port/opds/v1.2/catalog

I did that and it started working.


:raised_hands: amazing. That gives me an idea of what’s going on.

We don’t include the server information in each reading session. We generate a hash that identifies the server. Then we do the opposite operation to find the server configuration based on that hash.

It sounds like there’s a mismatch with the hashes, and we cannot find the correct server.

Could you share how you are configuring your server? We don’t need the actual URL or username password. But knowing how you are configuring the port (whether you are setting or omitting it) would help.

Initially I had it like this

Host: http://(ip address)/opds/v1.2/catalog
Port: 42XXX

Now it’s like this

Host: http://(ip address):42XXX/opds/v1.2/catalog
Port: 42XXX

If that’s what you mean? Since there is a section for the port number, I didn’t think it was necessary to add it to the host Url like in a browser

Interesting :thinking:

@_Wyldphyre, are you also using an IP address or a domain name?

I think Desh is right.

I had this (IP is static)

Port: 8181

As soon as I changed it to be

Port: 8181

I could load the issue from the “Reading Now” screen

1 Like

Thanks for confirming. We’ll try to reproduce the problem and fix it in the next release.

Also reproduced on my end. Wasn’t working when using https://my.komga.server/ but working with https://my.komga.server:443/. Thanks!

1 Like