Bug on 2.1.3

Hello Devs!
After yesterday’s update, whenever I open the app and swipe down to close a comic and go to the library, another comic opens automatically.
It seems that I can’t visit the library page nor import Stuff.

The problem persists and in 2.1.4.

I’ve tried to uninstall and empty the library, but even with only one comic in it, it does the same.
When you close it, it reopens.

I have an iPad Pro 12.9

Hi @Freddeus

We’ve received a few reports about this but we haven’t been able to reproduce the problem.

Could you give us some more information?
Does this also happen if you close the comic file using the menu instead of swiping down to close?

Hi @dani

Yes, it happens in both ways of closing the file, in portrait and landscape mode as you can see in the video here: https://streamable.com/0zsi4o

What I’ve tried:

  1. Uninstall the app but keep the data, then reinstall the app.
  2. Delete the app and data, then reinstall the app. While empty all seemed Ok. The bug occurs after adding even one comic and opening it.

ios 14.0.1 / ipad pro 2020 12.9


Would you be happy to test a beta build that we can use to gather more information to understand what’s causing the bug?

I’ve tested the app in iOS 14 on an iPad Pro and iPhone 11 Pro and I can’t reproduce the problem.

Please, join the beta here https://testflight.apple.com/join/rSjTNTaB and we’ll send a new build today. This build won’t fix anything, but will collect enough information for us to understand what’s happening.

Thank you for allowing me to help!
I’ve installed the beta over the 2.1.4 and now it crashes ehen i try to open it.

Oh, :man_facepalming: I think you installed an old version and it’s crashing because the database is not compatible. I think Testflight is showing the latest beta available. I’m uploading a new build now. It should be available today.

Yes, it was 2.1.0.

When there is a new build i will download and come back to you.

For the moment i uninstalled everything

Hi @dani any chance I can join TestFlight also. Am reading comics daily and would be happy to provide feedback here. Thanks.

I’m having the exact same issue as in the video. Panels 2.1.4, on iPadOS 14.2 beta 2, 6th generation iPad.

@sachin absolutely. Any additional information will be very helpful. Thank you so much for chipping in.

The link is public. Join the beta and hopefully Apple will approve the beta today.

Is anyone here testing the 2.1.5 Testflight? any difference?

I’m gettings some logs but they look like the comics are being opened triggered by user inputs, not automatically.

Can someone confirm if the bug still persists?

2.1.5 works fine!

I’ve respoded through testflight but don’t know if you got it.

Actually both the betas that you’ve uploaded worked fine. The bug only occurs in the released version 2.1.4

Amazing. I changed something that I thought might be related. Luckily it worked :smiley:!

Apple changed some things in iOS 14. Some APIs don’t behave exactly the same and they were causing Panels to trigger these behaviours. :sweat:

I’ll send 2.1.5 to AppStore review today.

Thanks for testing it and confirming it works :raised_hands: it was super helpful.

Anytime, @dani!

1 Like