2.15.1 crashes for pretty much every interaction with sidebar

I just updated to 2.15.1 on my iPad and found that it is super broken.

This is what I’ve seen:

  • Opening the app shows me the person with the magnifying glass
  • I then open the sidebar and essentially every option I tap crashes the app immediately or within about a second. This includes the “…” button, the profile button to access settings, libraries (including Komga, and on my ipad), favourites (saved ‘on deck’ for Komga), Search, Download, Reading Now, etc.

I’ve also seen it crash when:

  • sometimes when opening the sidebar
  • when switching back to the app and the sidebar is open

We have 29 crash logs from a single user. I assume it’s you :sweat:

We are going to submit a new Testflight build that hopefully fixes this.
Do you remember what import services you have connected? Looking at the crash log, it seems the crash happened because of an inconsistency between the number of services connected and the buttons on the sidebar.

Also, if you can make a screen recording and send it to us, it would be useful :pray:

Pretty sure the only services connected are Komga. That’s all I see in the sidebar. I’ll make a recording now.

Here’s a video. Let me know if you need me to focus on something more.

With regards to the services I’ve got configured, as mentioned before, it should only be Komga. There’s a slim chance I had something else configured at some point ages ago, but I can’t recall anything at the moment.

Thanks for the video.

Install the new testflight here. We were working on improvements for the side panel, and it’s not done yet. But should allow us to know whether it fixes the issue for you or not.

Installed the test flight, and it’s better. However, the “Libraries” section is gone from my sidebar now and tapping on my favourited Komga “On Deck” does nothing. I tried to deleted that and add it again, but it crashes when I tap to delete after swiping.

With the Libraries section missing my only option is to import files from Komga, and even then I can’t access the file I just imported unless I search for it.

I just published a new Testflight that should fix these issues.

We are investigating why Favorites sometimes stop working. I’ve added logs to track the bug down.
Also being discussed here TestFlight 2.15.0: Favourites gone? - #4 by dani

I had to re-add my Komga (for some reason it said the authentication had expired, or something along those lines), and the favourite still doesn’t work.

It was looking good besides that, but then I tried to delete the favourite, figuring I’d try to create it again. But it crashed when I tried to delete the favourite. Crashes to the desktop with a prompt to report the issue and then when I try to open the app again it immediately crashes out in the same fashion

yeah, it’s just stuck in a crash loop on app open now

I got your crash reports from Testflight. I think I found the issue. I think you have two different connections to the same Komga server, and Panels doesn’t handle that correctly.
I’ve fixed that, and now you can have as many connections to the same server as you want. That should solve the crash.

I’m uploading a new Testflight.

That’s fixed the crashing. Thanks! I removed both the Komga connections, and added one back. With that I was able to recreate the “On Deck” favourite, but the favourite still doesn’t work, so I guess that problem is still there.

Looks things are mostly back to normal.

Oh! that makes sense. I tested it with existing favorites but not with new ones. I’ll fix that in a bit. The favorite you created won’t work. You’ll have to recreate it.

Fair enough. No rush on this last fix from my point of view.